Symptoms
When the Sample text is copied from "ACRS and SQL plug-in sample.doc" and placed in the ActiveCallRouting.ini file, the Call Routing server fails to work correctly.
The error logging file contains an entry indicating an SQL error.
Cause
The SQL statement in the document contains a quote character " that should not be there after %CallingDevice% parameter. See below:
SQL Query = SELECT * FROM tblChecking WHERE CLI=cstr(%CallingDevice%”) OR CallerDigits=cstr(%UserEnteredCode%)
Resolution
To fix the problem, edit the line in the ActiveCallRouting.ini file to read as below:
SQL Query = SELECT * FROM tblChecking WHERE CLI=cstr(%CallingDevice%) OR CallerDigits=cstr(%UserEnteredCode%)
This information relates to Avaya Active Telephony V5.0